UVA 10879(13.07.26)

Problem B
Code Refactoring
Time Limit: 2 seconds

"Harry, my dream is a code waiting to be
broken. Break the code, solve the crime."
Agent Cooper

Several algorithms in modern cryptography are based on the factthat factoring large numbers is difficult. Alicia and Bobby knowthis, so they have decided to design their own encryption scheme based on factoring. Their algorithm depends on a secret code, K, that Alicia sends to Bobby before sending him an encrypted message. After listening carefully to Alicia's description, Yvette says, "But if I can interceptK and factor it into two positive integers, A andB, I would break your encryption scheme! And the K values you use are at most 10,000,000. Hey, this is so easy; I can even factor it twice, into two different pairs of integers!"

Input
The first line of input gives the number of cases, N (atmost 25000).N test cases follow. Each one contains the code, K, on a line by itself.

Output
For each test case, output one line containing "Case #x: K = A * B = C * D", where A, B, C andD are different positiveintegers larger than 1. A solution will always exist.

Sample InputSample Output
3
120
210
10000000
Case #1: 120 = 12 * 10 = 6 * 20
Case #2: 210 = 7 * 30 = 70 * 3
Case #3: 10000000 = 10 * 1000000 = 100 * 100000



题意: 输入N, 代表K组数据

对每一组数据: 找出它的两对乘法式子, 得数为它本身, 但是两对乘法式子中的因子不许有1


特别注意点:不要用两重for循环, 判断i * j 是否等于 K, 这样的时间复杂度是n的平方, 且会超时哦

正确的做法应该是, 一个for循环, 用K对i取余, 若为0, 表示可整除, 然后算出整除后的数, 同时保存i和得数就OK, 这个方法的道理很简单, 因子是成对出现的~


AC代码:

#include<stdio.h>

int main() {
	int A, B, C, D;
	int N;
	int K;
	int cas = 0;
	scanf("%d", &N);
	while(N--) {
		scanf("%d", &K);
		int mark = 0;
		for(int i = 2; i < 25000; i++) {
			if(K % i == 0 && mark == 0) {
				A = i;
				B = K / i;
				mark = 1;
			}
			else if(K % i == 0 && mark == 1) {
				C = i; 
				D = K / i; 
				printf("Case #%d: %d = %d * %d = %d * %d\n", ++cas, K, A, B, C, D);
				break;
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值