ACM--Crossing River

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17
//经过分析有两种策略 
//一、1 2 5 10 
//策略:(t1,t2) (t1) (t3,t4) (t2) 此种策略需要t2+t1+t4+t2的时间 ,
//结果是运走了2人,原问题规模减2 
//二、1 7 8 9 
//策略:(t1,t4) (t1)  此种策略需要t4+t1的时间 
//结果是运走了1人,原问题规模减1 
//故f(n)=min(f(n-2)+t1+2*t2+tn,f(n-1)+t1+tn) 
//此方法是动态规划的思想。当然此题老师也讲了贪心的做法,不过需要证明,本人就不在此介绍了。 
#include<iostream>
#include<algorithm>
using namespace std;
int t[1002];
int f[1002];
int main()
{
	int Case;
	cin>>Case;
	while(Case--)
	{
		int n;
		cin>>n;
		for(int i=1;i<=n;i++)
        	cin>>t[i];
        sort(t+1,t+1+n);
		f[1]=t[1];
		f[2]=t[2];
		for(int i=3;i<=n;i++)
		   f[i]=min(f[i-2]+2*t[2]+t[1]+t[i],f[i-1]+t[i]+t[1]);
		cout<<f[n]<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值