水题--ants

直接上题目吧:ANTS(POJ No 1852)

ps大佬们都说这题是水题,我想我到了他们这个境界也可以这样说!!!

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output

4 8
38 207
我想我可以不用翻译了吧,反正也就我自己看o(╥﹏╥)o

思路还是自己整理一下:

题目上说,两只蚂蚁相遇后会向相反的方向继续走,爬到两端就会掉下去,输出需要的最短时间和最长时间,题目大概就是这个意思。

我们可以想象一下,如果两只蚂蚁相遇后,继续直走,不调头所用的时间和调头的时间是一样的!我们可以认为每个蚂蚁都是独立的,只不过它是相反的走,也是花一样的时间到头掉下去(语文不好,描述的不清楚,大概就是这个意思),这样问题就容易解决了,不管是要求最长时间还是最短时间,都是把每只蚂蚁都跑一遍就行了!

接下来看源代码把:

先看看c的,不过c要想AC有些地方需要注意的:每个变量用一次就行了,比如说这个for()中用i下一个就要换一个j或者别的,不然编译不通过,还有,c中没有min和max,要自己写

C:

 #include<stdio.h>
    #define max(x,y) (x>y?x:y)
    #define min(x,y) (x>y?y:x)
    #define MAX_N  1000000
    int main(void){
        int i,j,k;
        int L,n;
        int minT,maxT;
        int x[MAX_N];
        int t;
        scanf("%d",&t);
        while(t--)
        {
    
        minT=0;
    
        maxT = 0;
    
        scanf("%d %d",&L,&n);
    
        for(j= 0;j < n;j++){
            scanf("%d",&x[j]);
        }
    
        //求最短时间的,只要算出两个中所需时间大的就行
    
        for(i = 0;i < n;i++){
            minT = max(minT,min(x[i],L-x[i]));
        }
    
        //求需要的最长时间
        for(k = 0;k < n;k++){
            maxT = max(maxT,max(x[k],L-x[k]));
        }
       printf("%d %d\n",minT,maxT);
    
        }
    
        return 0;
    }

再来看见C++的,这个想的比较巧妙,没有用数组,耗用的内存比较小一点(ps这个不是我写的,网上找的,感觉很巧妙,拿来用一下)

#include <iostream>

#include <cstdio>

using namespace std;

int main()

{

    int t, l, n, pos, minans, maxans;
    scanf("%d", &t);;

    while(t--) {

        minans = 0;

        maxans = 0;
        scanf("%d%d", &l, &n);

        for(int i=1; i<=n; i++) {

            scanf("%d", &pos);

             minans = max(minans, min(pos, l - pos));

            maxans = max(maxans, max(pos, l - pos));

        }
        
        printf("%d %d\n", minans, maxans);

    }
    return 0;

}

这两个都可以AC,第一次写,格式有点不好看,多多见谅!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值