POJ 3126 Prime Path(bfs)

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22398 Accepted: 12401

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
这道题的题意是:给两个四位数的素数n,m。n每次只可以把自己四位数的 某一位改变,改变成的数也必须是素数。不能有前导0,因为必须是四位数。n不是只能变大,也可以变小的。求n最少要经过几次变化能变成m。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

#define MAX_N 10000

int prime[MAX_N] = {0};
int v[MAX_N];
struct path
{
	int x;
	int t;//最短次数
};

int main()
{
	for (int i = 2; i*i < MAX_N; i++)//素数打表
	{
		if (prime[i] == 0)
		{

			for (int j = 2; i*j < MAX_N; j++)
			{
				prime[i*j] = 1;
			}
		}
	}
	int t;
	cin >> t;
	while (t--)
	{
		int n, m;
		while (cin >> n >> m)
		{
			queue<path>q;              //初始化
			memset(v, 0, sizeof(v));
			path start;
			start.x = n;
			start.t = 0;
			q.push(start);
			v[n] = 1;

			while (!q.empty())     //BFS过程
			{	
				path temp = q.front();
				if (temp.x == m) { cout << temp.t << endl; break; }
				int a[4],b[4];
				for (int i = 0; i < 4; i++)
				{
					b[i]=a[i] = q.front().x % 10;
					q.front().x /= 10;
				}
				temp.t++;
				for (int i = 0; i < 4; i++)//通过数组使它只变一位
				{
					for (int j = 0; j < 10; j++)
					{
						b[i] = j;
						int c = b[0] + b[1] * 10 + b[2] * 100 + b[3] * 1000;
						if (b[3] == 0)continue;//去前导0
						if (prime[c] == 0&&v[c]==0)//是素数而且没选过 进入队列里
						{
							v[c] = 1;
							path t = temp;//必须要用新的变量  因为queue里传递的是引用
							t.x = c;
							q.push(t);
						}
					}
					b[i] = a[i];      //改完后要复原,保证只改一次
				}
				q.pop();   
			}

		}

	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值