POJ2253 Frogger (最短路)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

这个就是根据迪杰斯特拉算法做的。

题目要求不是最短路,而是青蛙能够到达目的地,最小的跳跃范围(在跳跃范围内的可以随便跳)。

每次就是选取他从现在跳跃点,到下一点的跳跃的最小一步,取所有最小步中的最大值就是答案了。

最后结果要输出一个空行。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
using namespace std;

int X[1000];//序号就是石头的序号
int Y[1000];
int vis[1000][1000];
struct edg
{
	int from;//起始的石头序号
	int to;//到达的石头序号
	double cost;//距离
	bool operator <(const edg &a)const {
		return cost > a.cost;
	}
};



int main()
{
	int n,cnt=0;
	while (scanf("%d",&n)!=EOF&&n)
	{
		double ans = -1;
		memset(vis, 0, sizeof(vis));
		priority_queue<edg>q;
		cnt++;
		for (int i = 0; i < n; i++)
		{
			scanf("%d%d", &X[i], &Y[i]);//0=start  1=end
		}
		vis[X[0]][Y[0]] = 1;
		edg e1;
		e1.from = 0;
		e1.to = 1;
		e1.cost = sqrt((X[0] - X[1])*(X[0] - X[1]) + (Y[0] - Y[1])*(Y[0] - Y[1]));
		q.push(e1);
		for (int i = 2; i < n; i++)
		{
			edg t;
			t.from = 0;
			t.to = i;
			t.cost = sqrt((X[0] - X[i])*(X[0] - X[i]) + (Y[0] - Y[i])*(Y[0] - Y[i]));
			if (t.cost < e1.cost)q.push(t);//如果超过了这个距离就没有意义了,减少队列的负担
		}
		while (!q.empty())
		{
			edg t = q.top();
			q.pop();
			ans = max(t.cost, ans);
			if (t.to == 1)break;
			vis[X[t.to]][Y[t.to]] = 1;
			for (int i = 0; i < n; i++)
			{
				if (!vis[X[i]][Y[i]])
				{
					edg t1;
					t1.from = t.to;
					t1.to = i;
					t1.cost = sqrt((X[t1.from] - X[i])*(X[t1.from] - X[i]) + (Y[t1.from] - Y[i])*(Y[t1.from] - Y[i]));
					if (t1.cost < e1.cost)q.push(t1);
				}
			}
		}
		printf("Scenario #%d\nFrog Distance = %0.3f\n", cnt, ans);
		puts("");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值