【最短路径练习】Frogger

Frogger

问题描述

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414 

思路

dijkstra的变形,具体看注释

代码样例

//B-Frogger
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
#define INF 1<<29
int n;
struct Point{
	int x, y;
}; 
Point point[205];
double dis[205][205];
double d[205];	//储存当前点到其他点的距离
double get_dis(Point a, Point b){
	return sqrt((double)((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)));
}
void dijkstra(){
	int v;
	double MIN;
	int vist[205];	//vist[i]=0时,未访问; vist[i]=1时,已访问过
	for(int i=1; i<=n; i++){
		vist[i]=0;	//初始化
		d[i]=dis[1][i];	//储存起点到其他点的距离 
	}
	for(int i=1; i<=n; i++){
		MIN=INF;
		for(int j=1; j<=n; j++){
			if(!vist[j]&&d[j]<MIN){
				v=j;	//距离当前点最近的点 
				MIN=d[j];
			}
		} 
		vist[v]=1;	//标记之
		for(int j=1; j<=n; j++){
			//路径最短,而跳的最远的那次是跳了多远呢 
			d[j]=min(d[j],max(d[v],dis[v][j]));
		}
	}//数组d最终存放的是起点到其他点的最短路径中跳的最远的那次的长度 
}
int main(void){
	int counter=0, a, b, c;
	while(cin>>n&&n){//n个点 
		for(int i=1; i<=n; i++){
			cin>>point[i].x>>point[i].y;
		}
		for(int i=1; i<=n; i++){
			for(int j=1; j<=n; j++){ 
				dis[i][j]=dis[j][i]=get_dis(point[i], point[j]);
			} 
		}
		dijkstra();
		if(counter){
			cout<<endl;
		}
		printf("Scenario #%d\nFrog Distance = %.3f\n", ++counter, d[2]);
	}
	return 0;
}
  

犯过的错误。。。

在变量命名时,我命名了一个变量为min,却又使用了min函数,DEVC老是报错。。。最后我把变量min改名为MIN,才编译通过。所以,最好还是不要把变量和函数重名。

  • 1605集训计划第十六天任务
  • 按时完成完成
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值