HDU 1004 Let the Balloon Rise

 
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.                                                                                                                                                                     
This year, they decide to leave this lovely job to you.        
                                                                                                                                                                                                         
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 
Sample Output
  
  
red
pink

 

 

题意:第一行输入1个整数N范围是N[0,1000]n=0代表程序执行结束。

            接下来N行每行输入一个颜色,最后把颜色出现次数最多的输出。表示颜色的单词字符最多为15个。

代码

#include<stdio.h>
#include<string.h>
int main()
{
    int i,n,j,k,t;
    char a[1001][16];
    while(scanf("%d",&n),n)
    {
        int  b[1001]={0};
        for(i=0;i<n;i++)//每输入一个颜色就对它进行一次处理
        {
            scanf("%s",a[i]);
            for(j=0;j<=i;j++)
            {
                if(strcmp(a[i],a[j])==0)//查看前面是不是有这个颜色出现
                {
                    b[j]++;//如果出现则颜色次数+1
                    break;//并且跳出循环本次,否则它会把出现在第二次,第三……出现的相同颜色做累加
                }
            }
        }
        for(i=0;i<n;i++)//比较数组总最大的数,这个数就是颜色出现最多的颜色数组的下标
        {
            k=0;
            for(j=0;j<n;j++)
            {
                if(b[i]>=b[j])
                k++;
            }
                if(k==n)
                {
                    t=i;
                    break;
                }
        }
        printf("%s\n",a[t]);
    }
    return 0;
}



 

分析:第一次做的时候居然想到了用b[a[i]]++,后来发现[]里面的数是整形的而a[i]一个二进制的地址- -!
            定义一个二维数组来储存字符串
            第一个[ ]是行数
            第二个[ ]是每个字符串中字符的数量
            scanf("%s",a[i]);其中a[i]为该行一维数组的首地址,代表输出第i行,而第i行储存的就是第个字符串。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值