HDU 1061 Rightmost Digit

 

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 


 

Output
For each test case, you should output the rightmost digit of N^N.
 


 

Sample Input
  
  
2 3 4
 


 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 

 

题意:

求n^n模10

代码:

#include<stdio.h>

int exp_mod(int a,unsigned int n,int b)
{
	int t;
	if(n==0||n==1)
	return n==0?1:a;
	t=exp_mod(a,n/2,b);
	t=t*t;
	if(n%2==1)t=t*a;
	return t%b;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		long long n;
		scanf("%lld",&n);
		printf("%d\n",exp_mod(n%10,n,10));
	}
	return 0;
}




 

分析:

代码是在网上找的模版,第一次做是想找规律的可是实在是太繁琐勒(其实是我懒= =! ),就上网看看有没有更简单的方法,才知道这样的题有模版,就是快速幂取模.果断背下来....

下面是我经过在网上找的解析:

快速幂取模就是在O(logn)内求出a^n mod b的值。算法的原理是ab mod c=(a mod c)(b mod c)mod c 
 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值