HDU 1008 Elevator

 Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case.
Sample Input
  
  
1 2 3 2 3 1 0
 
Sample Output
  
  
17
41

 

题意:

输入N,然后是N个整数,没个数代表电梯所在的层数,设电梯是从0层开始的。没过一个楼层需要停留5s,上一层需要6s,下一层需要4s,输出电梯停止的时候所用的时间。

代码:

#include<stdio.h>
int main()
{
    int n,i,sum;
    int a[105];
    while(scanf("%d",&n),n)
    {
        sum=0;
        a[0]=0;
        for(i=1;i<=n;i++)//每输入一个数就处理一次
        {
            scanf("%d",&a[i]);
            if(a[i]-a[i-1]>0)//判断输入的数与前一个数的差>0则说明是上,<0则是下
            {
                sum=sum+(a[i]-a[i-1])*6;
            }
            if(a[i]-a[i-1]<0)
            {
                sum=sum+(a[i-1]-a[i])*4;
            }
        }
        printf("%d\n",sum+n*5);//输出的时候别忘了加上没一楼层都停留5S
    }

    return 0;

}

分析:理解了题意,一点难度都没有。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值