The ? 1 ? 2 ? ... ? n = k problem uva 10025

 The ? 1 ? 2 ? ... ? n = k problem

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701

题意:很容易理解;

解决方案:先求根,从根开始枚举,枚举到他的数列的和与原数的差是偶数的那个就是最小的,另外注意0的处理。

#include<iostream>
#include<cstdio>
#include<math.h>
using namespace std;
int main()
{
    long long t,k;
    cin>>t;
    while(t--)
    {
        scanf("%lld",&k);
       // cout<<k;
        if(k<0) k=fabs(k);
       // cout<<k;
        long long root_k=sqrt(k);
        //cout<<root_k;
        for(;;)
        {
            if(root_k!=0&&(root_k*(root_k+1)/2)>=k)
            {
               long long s=root_k*(root_k+1)/2;
                long long sub=(s-k);//cout<<root_k<<endl;
                if(sub%2==0&&(sub)/2<=s) {cout<<root_k<<endl;break;}
               // else root_k++;

            }
              root_k++;
        }
        if(t)
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值