NYOJ 354 Stripies

Stripies

时间限制: 1000  ms  |  内存限制: 65535  KB
难度: 1
描述
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
输入
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
输出
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
样例输入
3
72
30
50
样例输出
120.000

 

思路:理解题意。Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
这句是关键。

 

#include <stdio.h>
#include <math.h>
#include <stdlib.h>

int comp ( const void *a, const void *b )
{
    return * ( int * ) b - * ( int * ) a;
}

int main()
{
	double sum;
	int m,i;
	int a[110];
	scanf("%d",&m);
	for (i=0; i<m; i++)
	{
		scanf("%d",&a[i]);
	}
	qsort(a,m,sizeof(int),comp);
	sum = 2 * sqrt(a[0] * a[1]);
	for (i=2; i<m; i++)
	{
		sum = 2*sqrt(sum * a[i]);
	}
	printf("%.3f\n",sum);
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值