A^B mod C


Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<=1000000000).

 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

 Output

For each testcase, output an integer, denotes the result of A^B mod C.

 Sample Input

3 2 42 10 1000

 Sample Output

124
#include<stdio.h>
__int64 power(__int64 a,__int64 b,__int64 c)
{
	__int64 ans=1;
	while(b)
	{
		if(b&1)  //当b为奇数时
		{
			ans=(ans*a)%c;   // a的99次方的等于a的49次方的平方,还要再乘以a
			b--;
		}
		b/=2;   //二分
		a=a*a%c;    //  a的98次方的等于a的49次方的平方
	}
	return ans;
	
}
int main()
{
	long  a,b,c;
	while(scanf("%ld%ld%ld",&a,&b,&c)!=EOF)
	{
	
		printf("%ld\n", power(a,b,c));
	}
	return 0;
}

采用了二分法快速幂
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值