动态规划Q - Beans HDU - 2845

注 若Java 遇到 EOF 终止 只能用 hasNextLine()来判断
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Now, how much qualities can you eat and then get ?
Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn’t beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.
Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
Sample Output
242



import java.util.ArrayList;
import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;

/**
 * Created by 95112 on 11/3/2017.
 */
public class QBeans {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        ArrayList<String> answers = new ArrayList<>();
        int N, M;
        N =0 ;
        M = 0;
        while (scanner.hasNextLine()){
            String input = scanner.nextLine();
            String p = "(\\d+)";
            Pattern pattern = Pattern.compile(p);
            Matcher matcher = pattern.matcher(input);
            String[] deal = input.split(" ");
            if (matcher.find())
                N = Integer.valueOf(matcher.group(1));
            if (matcher.find())
                M = Integer.valueOf(matcher.group(1));
            if (N == 0 || M==0)
                break;
            long[] vertical = new long[N];
            long[][] map = new long[N][M];
            for (int i = 0; i < N; i++) {
                int j = 0;
                input = scanner.nextLine();
                matcher = pattern.matcher(input);
                while (matcher.find())
                    map[i][j++] = Integer.valueOf(matcher.group(1));
                long[] dp = new long[M + 1];
                dp[0] = 0;
                dp[1] = map[i][0];
                for ( j = 2; j <= M; j++) {
                    dp[j] = max(dp[j - 1], dp[j - 2] + map[i][j - 1]);
                }
                vertical[i] = dp[M];
            }

            long[] dp = new long[N + 1];
            dp[1] = vertical[0];
            for (int i = 2; i <= N; i++) {
                dp[i] = max(dp[i - 1], dp[i - 2] + vertical[i - 1]);
            }
          answers.add(dp[N]+"");

        }
        for (String answer : answers)
            System.out.println(answer);
    }
    private static long max(long a,long b)
    {
        if (a>b)
            return a;
        else
            return b;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值