hdu 5143 NPY and arithmetic progression(枚举)

NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers, $a_1, a_2, a_3, a_4$, which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
Input
The first line contains a integer T — the number of test cases (1≤T≤1000001≤T≤100000).
The next T lines,each contains 4 integers a1,a2,a3,a4(0≤a1,a2,a3,a4≤109)a1,a2,a3,a4(0≤a1,a2,a3,a4≤109).
Output
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
Sample Input

3
1 2 2 1
1 0 0 0
3 0 0 0

Sample Output

Yes
No
Yes

/*
解题思路:等差数列共三种情况:123 234 1234 用光所有数字,组成0到多个长度至少为3的等差数列 组不成等差数列返回No 组成返回Yes
            1. a个1 b个2 c个3 d个4 组成公差为1的等差数列后 剩余的数字大于3的话可以自身组成公差为0的等差数列(例如组成2个123 一个333 那么输入的abcd依次为2250)
            2. a个1 b个2 c个3 d个4 刚好用完,组成多个公差为1的等差数列
*/

#include<stdio.h>
#include<string.h>
#define MAX 100000
#define MAX2 1000000000
int main()
{
    int i,j,k,T,flag;
    int a,b,c,d;
    scanf("%d",&T);
    if (T<=MAX)
    {
    while(T--){
        scanf("%d%d%d%d",&a,&b,&c,&d);
        flag=0;
        if(a<=MAX2||b<=MAX2||c<=MAX2||d<=MAX2){
            for (i = 0; i <= 2; i++)    //情况1:123
                for (j = 0; j <= 2; j++)//情况2:234                
                    for (k = 0; k <= 2; k++)//情况3:1234                    
                        {if (((a-i-k==0)||(a-i-k>=3))&&((b-i-j-k==0)||(b-i-j-k>=3))&&((c-i-j-k==0)||(c-i-j-k>=3))&&((d-j-k==0)||(d-j-k>=3)))
                            {flag=1;break;}
                    }




        if (flag)
            printf("Yes\n");        
        else
            printf("No\n");
    }
    }    
    }


    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值