hdu 5143 NPY and arithmetic progression

Problem Description
NPY is learning arithmetic progression in his math class. In mathematics, an arithmetic progression (AP) is a sequence of numbers such that the difference between the consecutive terms is constant.(from wikipedia)
He thinks it's easy to understand,and he found a challenging problem from his talented math teacher:
You're given four integers,  a1,a2,a3,a4 , which are the numbers of 1,2,3,4 you have.Can you divide these numbers into some Arithmetic Progressions,whose lengths are equal to or greater than 3?(i.e.The number of AP can be one)
Attention: You must use every number exactly once.
Can you solve this problem?
 

Input
The first line contains a integer T — the number of test cases ( 1T100000 ).
The next T lines,each contains 4 integers  a1,a2,a3,a4(0a1,a2,a3,a4109) .
 

Output
For each test case,print "Yes"(without quotes) if the numbers can be divided properly,otherwise print "No"(without quotes).
 

Sample Input
  
  
3 1 2 2 1 1 0 0 0 3 0 0 0
 

Sample Output
  
  
Yes No Yes
Hint
In the first case,the numbers can be divided into {1,2,3} and {2,3,4}. In the second case,the numbers can't be divided properly. In the third case,the numbers can be divided into {1,1,1}.

题目描述

有a1个1,a2个2,a3个3,a4个4,问能否不重不漏的划分成一些长度大于等于3的等差数列(一个数列可以出现多次)?

官方思路:可以发现等差数列只有(123,234,1234和长度>=3的常数列),如果选择非常数列(123,234,1234)数量大于等于3,可以变为三个或4个常数列,例如(123,123,123)变为(111,222,333)。

dfs

#include<iostream>
#include<stdio.h>
#include <string.h>
#include <algorithm>
using  namespace std;
bool dfs(int a,int b,int c,int d)
{
    if(a+b+c+d==0)  //a,b,c,d==0
    {
        return true;
    }
    if((a>=3||a==0) && (b>=3||b==0) && (c>=3||c==0) && (d>=3||d==0)) //部分为0,或者大于3
    {
        return true;
    }
    if(a>=1 && b>=1 && c>=1 && d>=1) //1234型
    {
        if(dfs(a-1, b-1, c-1, d-1))
        {
            return true;
        }
    }
    if(a>=1 && b>=1 && c>=1)  //123型
    {
        if(dfs(a-1, b-1, c-1, d))
        {
            return true;
        }
    }
    if(b>=1 && c>=1 && d>=1) //234型
    {
        if(dfs(a, b-1, c-1, d-1))
        {
            return true;
        }
    }
    return false;
}
int main()
{
    int t,a,b,c,d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&a,&b,&c,&d);
        if(dfs(a,b,c,d))
        {
            printf("Yes\n");
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值