HDU 1316-How Many Fibs?(大数类)

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4295    Accepted Submission(s): 1689


Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
给出一个范围[l,r],求此范围内的斐波那契数的个数。打表即可。
import java.io.*;
import java.util.*;
import java.math.*;
public class Main {
       public static void main(String[] args){
    	   Scanner in=new Scanner(System.in);
    	   BigInteger a,b,cnt;BigInteger[] f=new BigInteger[10010];
    	   f[1]=BigInteger.valueOf(1);f[2]=BigInteger.valueOf(2);
    	   for(int i=3;i<10005;i++)
    		   f[i]=f[i-1].add(f[i-2]);
    	   while(in.hasNext()){
    		   cnt=BigInteger.ZERO;
               a=in.nextBigInteger();b=in.nextBigInteger();
               if(a.equals(BigInteger.valueOf(0))&&b.equals(BigInteger.valueOf(0)))break;
    	       for(int i=1;i<10000;i++)
    		      if((f[i].compareTo(a)==0||f[i].compareTo(a)==1)&&(f[i].compareTo(b)==0||f[i].compareTo(b)==-1))
    		    	  cnt=cnt.add(BigInteger.valueOf(1));
    	       System.out.println(cnt);
    	   }
       }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值