杭电1316(How Many Fibs?)

27 篇文章 0 订阅
7 篇文章 0 订阅

点击打开杭电1316

Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 


 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 


 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 


 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 


 

Sample Output
  
  
5 4

 

代码实现
import java.math.BigInteger;
import java.util.Scanner;
class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        BigInteger[] fib=new BigInteger[1005];
        fib[1]=BigInteger.valueOf(1);
        fib[2]=BigInteger.valueOf(2);
        for(int i=3;i<1005;i++){
        	fib[i]=fib[i-1].add(fib[i-2]);
        }
        int numb;
        while(sc.hasNextBigInteger()){
	        BigInteger a=sc.nextBigInteger();
            BigInteger b=sc.nextBigInteger();
            if(a.equals(BigInteger.valueOf(0))&&b.equals(BigInteger.valueOf(0))){
            	break;
            }
        	numb=0;
            for(int i=1;i<1005;i++){
            	if(fib[i].compareTo(a)>=0&&fib[i].compareTo(b)<=0){
            		numb++;
            	}
            	if(fib[i].compareTo(b)>0){
            		break;
            	}
            }
            System.out.println(numb);
        }
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值