Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 196696 Accepted Submission(s): 45933
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Author
Ignatius.L
Recommend
觉得烦的时候就来A题,这句话说的一点也不错...只是最近烦的次数有点多,A题之心也不如以前那般狂热。
好!闲话少说,这题是动态规划DP的经典问题,题意就是求一段数列的最大连续子序列和,然后让你输出三个数字,
分别是该段数列的最大连续子序列和的值,最大连续子序列第一个数的下标(下标从1开始),最大连续子序列最后一个数的下标。
思路很简单,关键是找出状态转移方程。
1.把数列第一个数存入dp[0].
2.首先你要明确最大连续子序列和是什么意思,就是从中取两个数之间相加最大!是吧,它的特点一定要抓住,就是这个和一定比
它的子序列中任何一个数要大,所以就有了判断条件。
3.状态转移方程,max( dp[i-1] + a[i] , a[i] )
#include <iostream>
#include <cstdio>
using namespace std;
int a[100001],dp[100001];
int main()
{
int T,n,i=0;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
dp[0] = a[0];
int start = 0,end = 0,max = -1001;
int first = 0,last = 0;
for(int i=0;i<n;i++)
{
if(dp[i-1]+a[i]>=a[i]) //判断条件
{
dp[i] = dp[i-1]+a[i];
end = i;
}
else
{
dp[i] = a[i];
start = end = i;
}
if(max<dp[i])
{
max = dp[i];
first = start;
last = end;
}
}
printf("Case %d:\n%d %d %d\n",++i,max,first+1,last+1);
if(T!=0)
{
printf("\n");
}
}
return 0;
}