HDU-1003-Max Sum(dp经典问题-最大连续子序列和)

210 篇文章 0 订阅
206 篇文章 0 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 196696    Accepted Submission(s): 45933


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1176  1087  1069  1058  1159



觉得烦的时候就来A题,这句话说的一点也不错...只是最近烦的次数有点多,A题之心也不如以前那般狂热。

好!闲话少说,这题是动态规划DP的经典问题,题意就是求一段数列的最大连续子序列和,然后让你输出三个数字,

分别是该段数列的最大连续子序列和的值,最大连续子序列第一个数的下标(下标从1开始),最大连续子序列最后一个数的下标。

思路很简单,关键是找出状态转移方程。


1.把数列第一个数存入dp[0].

2.首先你要明确最大连续子序列和是什么意思,就是从中取两个数之间相加最大!是吧,它的特点一定要抓住,就是这个和一定比
   
    它的子序列中任何一个数要大,所以就有了判断条件。

3.状态转移方程,max( dp[i-1] + a[i] , a[i] )


#include <iostream>
#include <cstdio>
using namespace std;
int a[100001],dp[100001];
int main()
{
    int T,n,i=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        dp[0] = a[0];
        int start = 0,end = 0,max = -1001;
        int first = 0,last = 0;
        for(int i=0;i<n;i++)
        {
            if(dp[i-1]+a[i]>=a[i])         //判断条件
            {
                dp[i] = dp[i-1]+a[i];
                end = i;
            }
            else
            {
                dp[i] = a[i];
                start = end = i;
            }
            if(max<dp[i])
            {
                max = dp[i];
                first = start;
                last = end;
            }
        }
        printf("Case %d:\n%d %d %d\n",++i,max,first+1,last+1);
        if(T!=0)
        {
            printf("\n");
        }
    }
    return 0;
}

 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值