HDU 2147 kiki's game

/*
题目大意:在m*n的棋盘上,一开始在他的右上角,只能向下和向左移动,假设两人都很聪明,谁先不能走,就算输了。
难点详解:将图画出来,一切都明了了。
关键点:博弈
解题人:lingnichong
解题时间:2014/08/06    19:47
解题感受:如果能将图画出来,就能发现其中的规律。是组合游戏中比较简单的
*/

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 6547    Accepted Submission(s): 3898


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   1850  1846  1848  1849  1517 
 




#include<stdio.h>
int main()
{
	int n,m;
	while(scanf("%d%d", &n, &m),(m!=0||n!=0))
	{
		if(m*n%2==0)
		printf("Wonderful!\n");
		else
		printf("What a pity!\n");
	} 
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值