HDU 1070 Milk

116 篇文章 0 订阅
9 篇文章 0 订阅

/*
中文题意:选择最便宜的牛奶,当一样便宜时,选择体积较大的。(一开始没注意,WA了还几次)。
中文翻译:1、这个人只喝距生产最多5天的牛奶。

    2、他每天要喝200ml的牛奶。

    3、如果他发现牛奶瓶里面的牛奶少于200ml,就会将它扔掉。(个人感觉他有点浪费东西)

    4、所有的牛奶在超市里面都是当天生产的。
题目大意:选择最便宜的牛奶
解题思路:用结构体储存一样的信息和比较单价(在5天以内),即就是性价比。另外就是当性价比一样时,选择体积大的
难点详解:在输入牛奶名字的时候,单价、体积时,用结构体储存,在算性价比时去除V小于200的,当V超过1000时,天数按5天计算。最后输出单价最小的就可以了。
关键点:结构体,理解题意
解题人:lingnichong
解题时间:2014-08-06 23:25:54
解题感受:结构体写的,注意题意要求就可以了。
*/

Milk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13555    Accepted Submission(s): 3309


Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

Sample Input
  
  
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

Sample Output
  
  
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
 


#include<stdio.h>
#include<string.h>
struct stu
{
	char name[110];
	double money;
	int V;
	int day;
}per[110];

int main()
{
	int T,N;
	int i,j;
	int temp;
	double min;
	scanf("%d", &T);
	while(T--)
	{
		min=100000;
		memset(per,0,sizeof(per));
		scanf("%d", &N);
		for(i = 0; i < N; i++)
		{
			scanf("%s%d%d", per[i].name, &per[i].money, &per[i].V);
			if(per[i].V>=200)
			{
				per[i].day = per[i].V/200;
				if(per[i].day>5)
				{
					per[i].money/=5;
				}
				else
				{
					per[i].money/=per[i].day;
				}	
			} 
			
			
		}
		for(i = 0; i < N; i++)
		{
			if(per[i].V>=200)
			{
				if(per[i].money==min)
				{
					if(per[i].V>per[temp].V)    {min=per[i].money;temp=i;}
				}
				else if(per[i].money<min)
				{
					min=per[i].money;
					temp=i;
				}
			}
		}
		printf("%s\n",per[temp].name);
		
	}
	 
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值