HDU 1070---Milk (JAVA解答)

Milk

Problem Description

Ignatius drinks milk everyday, now he is in the supermarket and he
wants to choose a bottle of milk. There are many kinds of milk in the
supermarket, so Ignatius wants to know which kind of milk is the
cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will
never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the
volumn of a bottle is smaller than 200mL, you should ignore it. Given
some information of milk, your task is to tell Ignatius which milk is
the cheapest.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

Output

For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

Sample Input

2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000

Sample Output

Mengniu
Mengniu
HintIn
the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case,
milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.

题目大意
条件:Ignatius 每天 喝牛奶 200ml ,牛奶放超过5天就不喝了,
商品:有多个牌子牛奶,给你每瓶奶的价格和容量。
输出:输出最便宜的牛奶。

注意点
算最便宜是按照 平均到每天的价格,还要考虑的细节是 当有平均到每天的价格相同的时候,优先大容量的。
代码如下:

package hlh;

import java.util.Scanner;
/**
 * @author<a href="mailto:953801304@qq.com">胡龙华</a>
 * @version 2017-5-14  下午8:05:52
 * @fileName p1070.java
 */

public class p1070 {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            String str1 [] = new String [n];
            sc.nextLine();// 收掉前面的字符,后面才能正常收一行
            String str2="";// 用来记录牛奶的牌子
            double min=Double.MAX_VALUE;//用存  牛奶的最小价格(这是平均到天的价格)
            int v = 0; // 用来记录容量,平均算到每天价格相等时,选择容量大的
            for(int i=0;i<n;i++){
                str1[i] = sc.nextLine();
                String s [] = str1[i].split(" ");// 拆开,分别拿到 牌子、价格、容量、
                //卫条件,防止容量小于200ML 
                if(Integer.parseInt(s[2])<200){
                    continue;
                }
                // 牛奶超过1000ml 只能算5天  以为过期了。
                int day = Integer.parseInt(s[2])/200<5?Integer.parseInt(s[2])/200:5;//算下牛奶可以喝几天
                double money  = Integer.parseInt(s[1])*1.0/day;// 算平均到每天的价格
                if(money<min){ // 价格更低就把信息存起来
                    min = money;
                    str2 =  s[0];
                    v = Integer.parseInt(s[2]);
                // 平均每天价格相等,选择容量大的
                }else if(money==min && v<Integer.parseInt(s[2])){
                        min = money;
                        str2 =  s[0];
                        v = Integer.parseInt(s[2]);
                }
            }
            System.out.println(str2);
        }
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值