HDU 1390 Binary Numbers【进制转换】

156 篇文章 0 订阅
13 篇文章 0 订阅

/*
中文题目 二进制数
中文翻译-大意 求解一个数的二进制数中所有的1的位置
解题思路:将给定的数转换成二进制,存入数组中,再控制一下格式,输出所有是1的位置即可。
关键点:格式控制,进制转换
解题人:lingnichong
解题时间:2014-08-26 20:55:43
解题体会:学会了一种格式控制
*/


Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2784    Accepted Submission(s): 1721


Problem Description
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.


Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.
 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
 

Sample Input
  
  
1 13
 

Sample Output
  
  
0 2 3
 

Source
 


#include<stdio.h>
int arr[10000],b[10000]={0};
int main()
{
	int t,n,k,i;
	scanf("%d",&t);
	while(t--)
	{
		k=0;
		scanf("%d",&n);
		while(n)
		{
			arr[k++]=n%2;
			n/=2;
		}
		int flag=0;
		for(i=0;i<k;i++)
		{
			if(arr[i]==1)//控制格式,是个很好的例子
			{
				if(flag==1)
					printf(" ");
				flag=1;
				printf("%d",i);
			}
		}
		printf("\n");
	}
	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值