HDU 1009 FatMouse' Trade【贪心】

/*
中文题目 胖老鼠的贿赂
中文翻译-大意 话说胖老鼠准备了M磅猫食,准备去贿赂猫警官,去换取它喜欢的咖啡豆。在仓库里面有N个房间,每个房间里面有J磅咖啡豆和F磅猫食。胖老鼠如果不能得到仓库里面的所有咖啡豆,它就选择能兑换多少是多少,让你求出老鼠最多能兑换多少咖啡豆
解题思路:将用猫食兑换咖啡豆的性价比排序。如果先排猫食,如果猫食相同按降序排咖啡豆是错误的,因为要使所获得的咖啡豆最多,要从性价比上面分析
难点详解:将性价比c排序,然后计算就可以了
关键点:排序,贪心
解题人:lingnichong
解题时间:2014-09-01 16:53:45
解题体会:排序,还要考虑怎样排序才是对的
*/


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43633    Accepted Submission(s): 14588


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 


#include<stdio.h>
#include<algorithm>
using namespace std;

struct node
{
    int a;
    int b;
    double c;
}arr[1100];

 int cmp(node x,node y)
 {
     return x.c > y.c;
 }    
 
int main()
{
    int m,n;
    int i,j;
    double sum;
    while(~scanf("%d%d",&m,&n))
    {
        if(m==-1&&n==-1)   break;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&arr[i].a,&arr[i].b);
            arr[i].c=(double)arr[i].a/arr[i].b;
        }    
        sort(arr,arr+n,cmp);
        
      //  puts("");
//        for(i=0;i<n;i++)
//        printf("%d %d\n",arr[i].a,arr[i].b);
//        puts("");
        
        sum=0;
        for(i=0;i<n;i++)
        {
            if(m >= arr[i].b)
            	sum+=arr[i].a;
        	else
        		sum+=m*(double)arr[i].a/arr[i].b;
    		m-=arr[i].b;
    		if(m<=0)    break;
        }    
        printf("%.3lf\n",sum);
    }    
    return 0;
}     

/*
5 3
7 2
4 3
5 2

7 2
5 2
4 3

13.333
20 3
25 18
24 15
15 10

24 15
15 10
25 18

31.500



*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值