POJ 1458 Common Subsequence(动态规划)

点我,我知道题目

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58460 Accepted: 24411

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij= zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

解题思路:



在提交的时候出现了runtime error,Time Limit Exceeded错误,分别是编写的时候出现错误导致程序中途崩溃,虽然在编译器上一切正常,还有是缺少程序终止条件,导致程序一直在运行,无法结束,导致超时。下面链接介绍超时和运行时间错误的博客。runtime errorTime Limit Exceeded

#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 1005
char sz1[MAXN],sz2[MAXN];
int MaxLen[MAXN][MAXN];
int main(){
	while(scanf("%s%s",sz1,sz2) != EOF){
		int length1 = strlen(sz1);
		int length2 = strlen(sz2);
		int i,j;
		for(i = 0; i <= length1; i++)
			MaxLen[i][0] = 0;
		for(i = 0; i <= length2; i++)
			MaxLen[0][i] = 0;
		for(i = 1; i <= length1; i++)
			for(j = 1; j <= length2; j++){
				if(sz1[i-1] == sz2[j-1])
					MaxLen[i][j] = MaxLen[i-1][j-1] + 1;
				else
					MaxLen[i][j] = max(MaxLen[i][j-1],MaxLen[i-1][j]);
			}
		printf("%d\n",MaxLen[length1][length2]);
	}
	return 0;
}
本题的分析由上课老师给的讲解,本处作为记录,方便之后的进一步学习。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值