PAT 1021. Deepest Root (25)(dfs求每个root的层数)(待修改)

题目

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print “Error: K components” where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components

待修改代码(有一个节点超时==)

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<int ,vector<int> > road;
vector<bool> visited;
vector<int> lever,maxlever;
int n;
int tem_max = 0,final_max = 0;
void dfs(int k){
    visited[k] = true;
    for (int i = 0; i <road[k].size() ; ++i) {
        int nx = road[k][i];
        if (!visited[nx]) {
            dfs(nx);
        }
    }
}

void cnt_dfs(int k){
    visited[k] = true;
    for (int i = 0; i <road[k].size() ; ++i) {
        int nx = road[k][i];
        if (!visited[nx]) {
            lever[nx] = lever[k] + 1;
            tem_max = max(lever[nx],tem_max);
            cnt_dfs(nx);
        }
    }
}
int main(int argc, char *argv[])
{
    ios_base::sync_with_stdio(false);
    cin >> n;
    int w,t;
    for (int i = 0; i < n-1; ++i) {
        cin >> w >> t;
        road[w].push_back(t);
        road[t].push_back(w);
    }
    int cnt = 0;
    visited.resize(n+1,false);
    //求有多少个孤岛
    for (int i = 1; i <= n; ++i) {
        if (!visited[i]) {
            dfs(i);
            cnt++;
        }
    }
    //如果为一个整体,分别计算每个节点为root情况下大最大的层数,最后再比较输出
    if (cnt == 1) {
        lever.resize(n+1);
        maxlever.resize(n+1);
        for (int i = 1; i <= n; ++i) {
            fill(visited.begin(),visited.end(),false);
            fill(lever.begin(),lever.end(),0);
            tem_max = 0;
            cnt_dfs(i);
            maxlever[i] = tem_max;
            //cout << " i: "<< i << " tem_max:" << tem_max << endl;
            final_max = max(final_max,tem_max);
        }
        for (int i = 1; i <=n ; ++i) {
            if (maxlever[i] == final_max) {
                cout << i << endl;
            }
        }
    }else {
        printf("Error: %d components\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值