官网
1043. Is It a Binary Search Tree (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
题目大意
- 1.判断是否是搜索树或者是镜像搜索数并构建和后序输出。
解题思路
- 1.这是我写的最新的版本,思路是最好的,但是段错误是什么鬼。
- 2.老版本地址,也有错。
待修改代码
#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
int n;
int p[1001];
bool flag = false;
typedef struct node{
int data;
node *left;
node *right;
}*Tree;
Tree buildBST(int l,int r){
if(l>r) return NULL;
Tree tree = new node();
tree->data = p[l];
if (l == r) {
tree->left = NULL;
tree->right = NULL;
return tree;
}
int i = r;
while (p[i] >= p[l]&&i>=l) {
i--;
}
int k = i;
while (k>l) {
if (p[k] >= p[l]) {
return NULL;
}
k--;
}
tree->left = buildBST(l+1,i);
tree->right = buildBST(i+1,r);
return tree;
}
Tree buildMBST(int l,int r){
if(l>r) return NULL;
Tree tree = new node();
tree->data = p[l];
if (l == r) {
tree->left = NULL;
tree->right = NULL;
return tree;
}
int i = r;
while (p[i] < p[l]&&i>=l) {
i--;
}
int k = i;
while (k>l) {
if (p[k] < p[l]) {
return NULL;
}
k--;
}
tree->left = buildMBST(l+1,i);
tree->right = buildMBST(i+1,r);
return tree;
}
void postOrder(Tree root){
if(root == NULL) return;
postOrder(root->left);
postOrder(root->right);
if (!flag) {
// cout << root->data ;
printf("%d",root->data);
flag = true;
}else {
//cout << " " << root->data;
printf(" %d",root->data);
}
}
int main(int argc, char *argv[])
{
//cin >> n;
scanf("%d",&n);
for (int i = 0; i < n; ++i) {
scanf("%d",&p[i]);
//cin >> p[i];
}
Tree root1 = buildBST(0,n-1);
Tree root2 = buildMBST(0,n-1);
if (root1!=NULL||root2!=NULL) {
if(root1 != NULL) postOrder(root1);
if(root2 != NULL) postOrder(root2);
printf("\n");
}else {
printf("NO\n");
}
return 0;
}