PAT 1092. To Buy or Not to Buy (20)(字符串操作)

官网

题目

1092. To Buy or Not to Buy (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is “Yes”, please tell her the number of extra beads she has to buy; or if the answer is “No”, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Figure 1
Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is “Yes”, then also output the number of extra beads Eva has to buy; or if the answer is “No”, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY
Sample Output 1:
Yes 8
Sample Input 2:
ppRYYGrrYB225
YrR8RrY
Sample Output 1:
No 2

题目大意

  • 1.Eva去买beads,店里只卖整个的,如果这个整个的beads有所有他想要的,告诉他额外的beads,反之告诉少了的数量,用0-9,a-z,A-Z代表不同的颜色。
  • 2.给苏俩列不超过1000 的beads,一个是商家的,一个是Eva想要的,如果yes,输出额外的beads,如果no,输出少了的个数。

AC代码

#include<iostream>
#include<deque>
#include<string>
#include<fstream>

using namespace std;
//fstream in("1.txt");
//#define cin in
int keep[256];
int main()
{
    string shop, Eva;
    cin >> shop;
    cin >> Eva;
    for (int i = 0; i < shop.length(); i++)
    {
        keep[(int)shop[i]]++;
    }
    bool flag = true;
    int no_number = 0, yes_number = 0;
    for (int i = 0; i < Eva.length(); i++)
    {
        if (keep[(int)Eva[i]]>0)
        {
            keep[(int)Eva[i]]--;
        }
        else{
            if (flag)
            {
                flag = false;
            }
            no_number++;
        }
    }
    if (flag)
    {
        cout << "Yes " << (int)shop.length()-(int)Eva.length() << endl;
    }
    else{
        cout << "No " << no_number << endl;
    }
    //cout << (int)'z' << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值