POJ - 3104 Drying(二分查找)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23628 Accepted: 5912

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

大致题意:一共有N件衣服 每件衣服有ai个单位的水 每分钟流失一个单位的水  烘干机每分钟能烘干K单位的水  问最少需要多少时间将衣服晾干

解题思路:用二分直接去枚举时间 再用这世间去遍历数组  小于mid的值不管  如果ai > mid  (ai - mid) / (k - 1)为这件衣服使用烘干机的时间  (注意向上取整和K == 1的情况)用cnt记录下所有衣服所需烘干机的时间 再去判断mid和cnt的关系 如果能在mid时间内找出来就去查找左边 反之右边

为什么(ai - mid) / (k - 1)为一件衣服所需烘干机的时间:我们选取的mid是最少所需晾干时间  那么衣服自然流失水分为mid  衣服所需烘干机烘干的水分为ai - mid, 烘干机每分钟烘干k 减去自然流失水分1为烘干机多流失的水分 那么(ai - mid) / (k - 1)为烘干机多烘干水分时间


#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long ll;
const int MAXN = 1e6 + 10;
ll tmp[MAXN];
ll n, k;
using namespace std;

int check(ll mid)
{
	ll cnt = 0;
	for (int i = 0; i < n; i++)
	{
		if (tmp[i] > mid)
			cnt += ceil((double)(tmp[i] - mid) / (double)(k - 1));//注意向上取整
	}
	if (cnt <= mid)
		return 1;
	else
		return -1;
}

ll BinarySearch(ll L, ll R)//二分找值
{
	while (L <= R)
	{
		ll mid = (L + R) >> 1;
		int flag = check(mid);
		if (flag == 1)
			R = mid - 1;
		else
			L = mid + 1;
	}
	return L;
}

int main()
{
	while (~scanf("%lld", &n))
	{
		ll maxn = -1;
		for (int i = 0; i < n; i++)
		{
			scanf("%lld", &tmp[i]);
			maxn = max(maxn, tmp[i]);
		}
		scanf("%lld", &k);
		if (k == 1)
			{ printf("%lld\n", maxn); continue; }
		int ans = BinarySearch(0, maxn);
		printf("%lld\n", ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值