POJ-3104-Drying

原题
It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.
Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).
Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.
Sample Input
sample input
3
2 3 9
5
sample input
3
2 3 6
5
Sample Output
sample output
3
sample output
2
题意:
有n件衣服,每个衣服有自己的含水量,含水量小于等于0即为晾干,自然风干每分钟含水量减一,吹风机每分钟含水量减m,问最短晾干时间。
题解:
首先能够想到的是可以二分查找全部自然风干的最少时间mid。但这一题不同的是在判断函数中用蛮力法判断mid是否满足条件是会出错。需要特殊处理(除数不为0)。
设某次二分出的一个值是mid:
1、对于一件ai值小于等于mid的衣服,直接晾干即可;
2、对于一件ai值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。
附上AC代码:

#include<cstdio>
#include<cmath>
#include<cstring>
long long  n,k;
long long a[100010];
bool dix(long long x)//判断
{
	long long i,time=0;
	if(k==1)//注意判断k是否为1,为1在下面会除以0,提交会RE 
		return true;
	for(i=0;i<n;++i)
	{
		if(a[i]>x)
			time+=(a[i]-x+k-2)/(k-1);//用向上取整函数ceil会WA,这里用K-2来向上取整 
	}
	if(time>x)
		return true;
	return false;
}
int main()
{
	long long max;
	long long i;
	while(scanf("%lld",&n)!=EOF)
	{
		max=0;
		for(i=0;i<n;++i)
		{
			scanf("%lld",&a[i]);
			if(max<a[i])
				max=a[i];//记录最大的湿度,作为二分的上界
		}
		scanf("%lld",&k);//注意数据范围
		long long left=0,right=max,mid;
		while(left<right-1)
		{
			mid=(left+right)/2;
			if(dix(mid))
				left=mid;
			else 
				right=mid;	
		}
		printf("%lld\n",right);
	}
	return 0;
}

欢迎评论!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值