hdoj-1086-You can Solve a Geometry Problem too 判断线段是否相交

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8683 Accepted Submission(s): 4227


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the number of intersections, and one line one case.

Sample Input
  
  
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

Sample Output
  
  
1 3

Author
lcy

Recommend
We have carefully selected several similar problems for you: 1392 2108 2150 1348 1147

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
const double esp=1e-7;
struct point{
	double x,y;
}p[110],q[110];
double cross(point a,point b,point c){
	return (c.x-a.x)*(c.y-b.y)-(c.x-b.x)*(c.y-a.y);
}
bool insert(point aa,point bb,point cc,point dd){
	if(max(aa.x,bb.x)<min(cc.x,dd.x))  return false;
	if(max(aa.y,bb.y)<min(cc.y,dd.y))  return false;
	if(max(cc.x,dd.x)<min(aa.x,bb.x))  return false;
	if(max(cc.y,dd.y)<min(aa.y,bb.y))  return false;
	if(cross(aa,bb,cc)*cross(aa,bb,dd)>0) return false;
	if(cross(cc,dd,aa)*cross(cc,dd,bb)>0) return false;
	return true;
}
int main(){
	int n;
	while(~scanf("%d",&n),n){
		int i,j;
		double s1,s2;
		for(i=1;i<=n;++i){
			scanf("%lf%lf%lf%lf",&p[i].x,&p[i].y,&q[i].x,&q[i].y);
		}
		int ncase=0;
		for(i=1;i<=n;++i){
			for(j=i+1;j<=n;++j){
			    if(insert(p[i],q[i],p[j],q[j])) ncase++;
			}
		}
		printf("%d\n",ncase);
     
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值