HDU - 4287 Intelligent IME 字典树

HDU - 4287
Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below: 
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o     
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z 
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences? 
 

Input

  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this: 
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words. 
 

Output

  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line. 
 

Sample Input

    
    
1 3 5 46 64448 74 go in night might gn
 

Sample Output

    
    
3 2 0
 
/*
Author: 2486
Memory: 3288 KB		Time: 93 MS
Language: G++		Result: Accepted
*/
//大家看懂题目这份代码基本就明白了
//很简单,先将数字进行字典树处理,然后通过一个s记录有多少个符合条件,最后用数字输出所有的结果
#include <cstdio>
#include <vector>
#include <string>
#include <iostream>
#include <queue>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int MAXN = 5000 + 5;
const int MAXM = 1000000 + 5;
struct node {
    int v,s,next[30];
    void init() {
        v = -1;
        s = 0;
        memset(next, -1, sizeof(next));
    }
} L[MAXM];

int N, M, T, tot;
char str[MAXN][10],op[10];


int Get_Num(char ch) {
    if(ch >= 'a' && ch <= 'c')return 2;
    if(ch >= 'd' && ch <= 'f')return 3;
    if(ch >= 'g' && ch <= 'i')return 4;
    if(ch >= 'j' && ch <= 'l')return 5;
    if(ch >= 'm' && ch <= 'o')return 6;
    if(ch >= 'p' && ch <= 's')return 7;
    if(ch >= 't' && ch <= 'v')return 8;
    if(ch >= 'w' && ch <= 'z')return 9;
}

int add(char * a, int len) {
    int now = 0;
    for(int i = 0; i < len; i ++) {
        int tmp = a[i] - '0';
        int next = L[now].next[tmp];
        if(next == -1) {
            next = ++ tot;
            L[next].init();
            L[now].next[tmp] = next;
        }
        now = next;
    }
    L[now].v = 0;
    return L[now].s;
}


void query(char * a, int len) {
    int now = 0;
    for(int i = 0; i < len; i ++) {
        int tmp = Get_Num(a[i]);
        int next = L[now].next[tmp];
        if(next == -1)return;
        now = next;
    }
    if(L[now].v == 0)
        L[now].s ++;
}

int main() {
    scanf("%d", &T);
    while(T --) {
        tot = 0;
        L[0].init();
        scanf("%d%d", &N, &M);
        for(int i = 0; i < N; i ++) {
            scanf("%s", str[i]);
            add(str[i], strlen(str[i]));
        }
        for(int i = 0 ; i < M; i ++) {
            scanf("%s", op);
            query(op, strlen(op));
        }
        for(int i = 0; i < N ; i ++) {
            printf("%d\n", add(str[i], strlen(str[i])));
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值