HDU 5747 Aaronson(汉明距离)

Aaronson

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 423    Accepted Submission(s): 255


Problem Description
Recently, Peter saw the equation  x0+2x1+4x2+...+2mxm=n . He wants to find a solution  (x0,x1,x2,...,xm)  in such a manner that  i=0mxi  is minimum and every  xi  ( 0im ) is non-negative.
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T105) , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (0n,m109) .
 

Output
For each test case, output the minimum value of  i=0mxi .
 

Sample Input
  
  
10 1 2 3 2 5 2 10 2 10 3 10 4 13 5 20 4 11 11 12 3
 

Sample Output
  
  
1 2 2 3 2 2 3 2 3 2
 

Source
 

首先知道汉明距离就是一个整数的二进制中1的个数,一般用英文popcount(n),来表示整数n的汉明距离,
这道题目的意思是说,给你一个n,m,求 解满足等式 x0+2x1+4x2+...+2mxm=n    ,的x0,x1,x2的最小和
按照bestcoder上面题解说,答案即为:popcount(n)popcount(2mn)+2mn⌋。
我们先不考虑m,将n的二进制数计算出来,然后裁剪掉,1<< m之前的部分,我们得到了,一个长度为m的二进制数,
然后我们还要剩余,用n除以最大的位数所代表的值1<<m,就可以得到n转化为m长的二进制数的时候的剩余的部分与1<<m的比例,然后加上它即是正确答案。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int T, n, m;


int bitscount(int x) {
	int ret = 0;
	while(x) {
		ret ++;
		x &= x - 1;
	}
	return ret;
}
int main() {
	while(~scanf("%d", &T)) {
		while(T --) {
			scanf("%d%d", &n, &m);
			int a = bitscount(n);
			if(m > 31) m = 31;
			int b = bitscount(n >> m);
			int c = n >> m;
			printf("%d\n", a - b + c);
		}
	}
	return 0;
}

               
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值