hdu 5747Aaronson(暴力)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5747

Aaronson

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 432    Accepted Submission(s): 261


Problem Description
Recently, Peter saw the equation x0+2x1+4x2+...+2mxm=n . He wants to find a solution (x0,x1,x2,...,xm) in such a manner that i=0mxi is minimum and every xi ( 0im ) is non-negative.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first contains two integers n and m (0n,m109) .
 

Output
For each test case, output the minimum value of i=0mxi .
 

Sample Input
  
  
10 1 2 3 2 5 2 10 2 10 3 10 4 13 5 20 4 11 11 12 3
 

Sample Output
  
  
1 2 2 3 2 2 3 2 3 2
题目大意: x0+2x1+4x2+...+2mxm=n  给m和m。求最小的x序列之和

所以预处理2 ^ 30 ,然后暴力

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int x[30];
int main()
{
    int t;
    x[0] = 1;
    for (int i = 1 ; i <= 29 ; i++ )
    {
        x[i] = x[i-1] * 2;
    }
    scanf("%d",&t);
    while (t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int res = 0;
        if (m > 29)
        {
            m = 29;
        }
        for (int i = m ; i >= 0 ; i--)
        {
            //printf("%d\n",x[i]);
            res += n / x[i];
            n = n % x[i];

        }
        printf("%d\n",res);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值