1021 Deepest Root (25 分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 分析:(代码来自柳婼https://github.com/liuchuo/PAT/blob/master/AdvancedLevel_C%2B%2B/1021.%20Deepest%20Root%20(25)%20.cpp

1.首先判断是否为树,即判断有几个连通分量;通过dfs,逐顶点遍历;若有多个连通分量,则直接输出Error;

2.为树时,以例一为样,最深根节点是最长路径的起点和终点,在第一遍dfs之后,我们可以得到n个最长路径的终点(因为可能可以分叉),但是起点已经在历史的洪流中被抛弃,所以要再对已经得到的最深根节点再次dfs,反向找回可爱的起点,纳入最深根节点的数组中,而在set中,insert进去的数据是会自动排序滴~所以从begin输出到end就是有序的顶点啦~

#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
int n,maxheight=0;
vector<vector<int>> v;
bool visited[10010];
set<int> s;
vector<int>temp;
void dfs(int node,int height){
    if(height>maxheight){
        temp.clear();
        temp.push_back(node);
        maxheight=height;
    }else if(height==maxheight){
        temp.push_back(node);
    }
    visited[node]= true;
    for(int i=0;i<v[node].size();i++){
        if(visited[v[node][i]]== false)
            dfs(v[node][i],height+1);
    }
}
int main(){
    cin>>n;
    v.resize(n+1);
    int a,b,cnt=0,s1=0;
    for(int i=0;i<n-1;i++){
        cin>>a>>b;
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for(int i=1;i<=n;i++){
        if(visited[i]== false){
            dfs(i,1);
            if(i==1){
                if(temp.size()!=0)
                    s1=temp[0];
                for(int j=0;j<temp.size();j++)
                    s.insert(temp[j]);
            }
            cnt++;
        }
    }
    if(cnt>=2){
        cout<<"Error: "<<cnt<<" components";
    } else{
        temp.clear();
        maxheight=0;
        fill(visited,visited+10010, false);
        dfs(s1,1);
        for(int i=0;i<temp.size();i++)
            s.insert(temp[i]);
        for(auto it=s.begin();it!=s.end();it++)
            cout<<*it<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值