畅通工程NO.3



Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input

    
    
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output

    
    
1414.2 oh!
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define lson  l, m, rt << 1
#define reson m+1, r, rt << 1 | 1
using namespace std;
typedef long long LL;
#define maxn 20000
int n,fa[maxn];
struct A
{
    int x,y;
    double v;
    bool operator< (const A&C)const
    {
        return v<C.v;
    }
} a[maxn];
struct B
{
    int x,y;
} s[maxn];
int F(int x)
{
    return fa[x]==x?x:fa[x]=F(fa[x]);
}
double G(int x1,int y1,int x2,int y2)
{
    return sqrt(double((x1-x2)*(x1-x2))+double((y1-y2)*(y1-y2)));
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int i,j;
        for(i=1; i<=n; i++)
            scanf("%d%d",&s[i].x,&s[i].y);
        int k=1;
        for(i=1; i<n; i++)
            for(j=i+1; j<=n; j++)
            {
                double temp=G(s[i].x,s[i].y,s[j].x,s[j].y);
                if(temp>=10&&temp<=1000)
                {
                    a[k].x=i;
                    a[k].y=j;
                    a[k++].v=temp*100;
                }
            }
        for(i=1; i<=k; i++)
            fa[i]=i;
        sort(a+1,a+k+1);
        double sum=0;
        int count=0;
        for(i=1; i<=k; i++)
        {
            int x=F(a[i].x),y=F(a[i].y);
            if(x!=y)
            {
                sum+=a[i].v;
                fa[x]=y;
                count++;
                if(count==n-1)
                    break;
            }
        }
        if(count==n-1)
            printf("%.1lf\n",sum);
        else printf("oh!\n");
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值