Ekka Dokka

Ekka Dokka
Ekka and his friend Dokka decided to buy a cake. They both love cakes and that’s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 2^63). And W will not be a power of 2.

Output
For each case, print the case number first. After that print “Impossible” if they can’t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input
3

10

5

12

Sample Output
Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

题意 :本题题意是给你一个数w,让你将他分为一个奇数n和偶数m,即w=m*n,如果有多组答案,就输出m较小的那一组。

思路;首先若w为奇数,一定为impossible。若w为偶数,因为给的w比较大,所以暴力枚举肯定会超时。因为本题要找一个较小偶数m,我们可以知道这个数一定是2的偶数倍,若为2的奇数倍,则他一定可以将那个奇数分给n,将自己变为一个更小的偶数。所以,我们要从从2的1次方枚举到2的63次方即可。

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll t,n,m,w,cnt=1,i;
int main()
{
	cin>>t;
	while(t--)
	{
		cin>>w;
		if(w%2==1)
		printf("Case %d: Impossible\n",cnt++);
		for(i=1;i<=63;i++)
		{
			ll t=pow(2,i);
			if(w%t==0&&(w/t)%2==1)
			{
				printf("Case %d: %lld %lld\n",cnt++,w/t,t);
				break;
			}
			
		}	
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值