【PAT】Insertion or Heap Sort 插入排序、堆排序、STL heap

26 篇文章 0 订阅
8 篇文章 0 订阅

原题链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805368847187968

1098 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

 

题意就是给出一组待排序的数组和一组排序过程中的数组,让你判断这是使用了插入排序还是堆排序,并且输出下一个排序步奏的数组。

好吧,看标题就知道我用了STL的heap,因为我发现牛客评论区和百度首页看了一下都没人用,明明STL自带有heap诶=。=看了一下其他很多题解也用了swap,sort之类的,所以用个heap也没有太大问题吧=。=,STL设计出来就是给人用的,基本思想掌握就好了,附上一下我的AC代码

#include<iostream>
#include<cstdio>
#include<cstdio>
#include<algorithm>
using namespace std;
int inse_arr[105],heap_arr[105],res_arr[105];
int n;
int equal_arr(int *a,int *b)//判断两个数组是否相等 
{
	for(int i=0;i<n;i++)
		if(a[i]!=b[i])
			return 0;
	return 1;
}
void next_inse(int i)//下一个插排序列 
{
	for(int j=i;j>0&&inse_arr[j]<inse_arr[j-1];j--)
		swap(inse_arr[j],inse_arr[j-1]);
}
void next_heap(int i)//下一个堆排序列 
{
	pop_heap(heap_arr,heap_arr+n-i+1);
	push_heap(heap_arr,heap_arr+n-i);
}
void print_arr(int *a)//打印数组 
{
	printf("%d",a[0]);
	for(int i=1;i<n;i++)
		printf(" %d",a[i]);
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&inse_arr[i]);//输入插排和堆排 
		heap_arr[i]=inse_arr[i];
	}
	make_heap(heap_arr,heap_arr+n);//建堆 
	for(int i=0;i<n;i++)
		scanf("%d",&res_arr[i]);
	for(int i=1;i<n;i++)
	{
		next_inse(i);
		if(equal_arr(inse_arr,res_arr))//判断下一个插排序列是否相等 
		{
			printf("Insertion Sort\n");
			next_inse(i+1);
			print_arr(inse_arr);
			return 0;
		}
		if(equal_arr(heap_arr,res_arr))//判断下一个堆排序列是否相等,放在这是不知道建堆算不算第一步 
		{
			printf("Heap Sort\n");
			next_heap(i);
			print_arr(heap_arr);
			return 0;
		}
		next_heap(i);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值