UVA_122: Trees on the level

42 篇文章 0 订阅

Description

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers suchas Thinking Machines' CM-5 are based on fat trees. Quad- andoctal-trees are fundamental to many algorithms in computer graphics.This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that printsa level-order traversal of each tree. In this problem each node of abinary tree contains a positive integer and all binary trees havehave fewer than 256 nodes.In a level-order traversal of a tree, the data in all nodes at agiven level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.For example, a level order traversal of the tree

picture28 is: 5, 4, 8, 11, 13, 4, 7, 2, 1.In this problem a binary tree is specified by a sequence of pairs(n,s) where n is the value at the node whose path from the root isgiven by the string s. A path is given be a sequence of L's andR's where L indicates a left branch and R indicates aright branch. In the tree diagrammed above, the node containing 13 isspecified by (13,RL), and the node containing 2 is specified by (2,LLR).The root node is specified by (5,) where the empty string indicates thepath from the root to itself. A binary tree is considered to becompletely specified if every node on all root-to-node paths inthe tree is given a value exactly once.

Input

The input is a sequence of binary trees specified as described above.Each tree in a sequence consists of several pairs ( n, s) as describedabove separated by whitespace. The last entry in each tree is (). Nowhitespace appears between left and right parentheses.All nodes contain a positive integer. Every tree in the input willconsist of at least one node and no more than 256 nodes. Input isterminated by end-of-file.

Output

For each completely specified binary tree in the input file, the levelorder traversal of that tree should be printed. If a tree is notcompletely specified, i.e., some node in the tree is NOT given a valueor a node is given a value more than once, then the string ``notcomplete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete


分析:

这道是一个直接的二叉树广度遍例问题,按照题目要求来处理就可以了。要注意所给的二元组可能没有数字,也可能没有路径串,这些情况都要很仔细的处理。此外,重复给出的节点以及未给出的节点都算输入错误,全部要输出not complete。在提交你的解答前请务必自己造几个这样的特殊情况检验一下,否则很可能WA。

此外,顺便提一下广度遍例的方法。需要建立一个链表(为加快插入和删除操作)来存储每一层的节点。先将根节点加入链表,然后开始依次(从左至右)遍例链表中的每一个节点。遇到一个不为空的节点,则输出之并将其删除,然后将它的两个子节点在原位置上插入,再向右继续下一个节点。一直到该层所有节点遍例结束,此时链表中的节点即为下一层的所有节点,再从头开始遍例即可。如此往复,一直到链表为空,则说明整棵树遍例结束。算法时间复杂度为O(n)。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
struct Node{
	bool have_value;
	int v;
	Node *left, *right;
	Node():have_value(false),v(0),left(NULL),right(NULL) {}
};
const int maxn = 300;
char s[maxn];
bool failed;
Node *root;
vector<int> ans;

Node* newnode(){ return new Node(); }

void remove_tree(Node* u) {
	if(u==NULL) return ;
	remove_tree(u->left);
	remove_tree(u->right);
	delete u;
}

void addnode(int v, char* s){
	int n = strlen(s);
	Node *u = root;
	for(int i=0; i<n; i++){
		if(s[i]=='L'){
			if(u->left==NULL) u->left = newnode();
			u = u->left;
		}else if(s[i]=='R'){
			if(u->right==NULL) u->right = newnode();
			u = u->right;
		}
	}
	if(u->have_value) failed = true;
	u->v = v;
	u->have_value = true;
}

bool read_input(){
	failed = false;
	remove_tree(root);
	root = newnode();
	while(1){
		if(scanf("%s",s)!=1)return false;
		if(!strcmp(s,"()"))break;
		int v;
		sscanf(&s[1],"%d",&v);
		addnode(v,strchr(s,',')+1);
	}
	return true;
}

bool bfs(vector<int>& ans){
	queue<Node*> q;
	ans.clear();
	q.push(root);
	while(!q.empty()){
		Node* u = q.front(); q.pop();
		if(!u->have_value) return false;
		ans.push_back(u->v);
		if(u->left != NULL) q.push(u->left);
		if(u->right != NULL) q.push(u->right);
	}
	return true;
}

int main()
{
	while(read_input())
	{
		if(!failed && bfs(ans) && !ans.empty()){
			for(int i=0; i<ans.size(); i++){
				if(i>0)putchar(' ');
				printf("%d",ans[i]);
			}
			putchar('\n');
		}else printf("not complete\n");
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值