UVA - 10129 Play on Words

42 篇文章 0 订阅
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing a single integer number N that indicates the number of
plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will
appear in the word. The same word may appear several times in the list.


Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the first letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is
possible.’. Otherwise, output the sentence ‘The door cannot be opened.’


Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok


Sample Output
The door cannot be opened.
Ordering is possible.

The door cannot be opened.


分析:把字母看成结点,单词看成有向边,则问题即判断是否存在欧拉回路:

1、有向图的无向图是否连通

2、根据欧拉回路判断是否每个点的入度和出度相等,如果不相等,则只存在一个点的入度=出度+1, 另一个出度=入度+1


#include <iostream>
#include <cstring>

using namespace std;
const int maxn = 26;
int vis[maxn];
int G[maxn][maxn];
int in[maxn];
int out[maxn];

bool dfs(int u)
{
	vis[u] = 1;
    for(int v=0; v<maxn; v++)
		if(G[u][v] && !vis[v]) dfs(v);
}

bool solve()
{
	int num1=0, num2=0;
    for(int i=0; i<maxn; i++)
    {
		if(in[i]!=out[i])
		{
			if(in[i]==out[i]+1)num2++;
			else if(out[i]==in[i]+1)num1++;
			else return false;
		}
    }
    if(num1&&num2 && num1+num2>2) return false;

	for(int i=0; i<maxn; i++)
		if(out[i]) {dfs(i);break;}
	for(int i=0; i<maxn; i++)
		if((in[i]||out[i]) && !vis[i])return false;
	return true;
}

int main()
{
	int T;
	cin >> T;
	while(T--)
	{
		int n;
        cin >> n;
        string s;
		memset(G, 0, sizeof(G));
		memset(in, 0, sizeof(in));
		memset(out, 0, sizeof(out));
        for(int i=0; i<n; i++)
        {
			cin >> s;
			G[s[0]-'a'][s[s.length()-1]-'a']++;
			out[s[0]-'a']++;
			in[s[s.length()-1]-'a']++;
        }
        if(solve())cout << "Ordering is possible." << endl;
        else cout << "The door cannot be opened." << endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值