tree(nyoj)

Tree

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB

 

// 输入前缀和中缀写出后缀式, 两种方法


//利用递归通过依次遍历前序来组织中序
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXLEN 27


void rebuid_binary_tree(char *pre_str, char *in_str, int len)
{
    char ch;
	if(len == 0)                                            //该递归的结束条件为该元素的左右两边都没有元素可以继续
		return ;
	ch = *pre_str;
	int i;
	for(i = 0; i < len; i++)
	{
		if(in_str[i] == *pre_str)
			break;
	}												
	rebuid_binary_tree(pre_str + 1, in_str, i);			                   //左子树
	rebuid_binary_tree(pre_str + i + 1, in_str + i +1, len - i - 1);       //右子树
	printf("%c", ch);                         
}

int main()
{
	char pre_str[MAXLEN], in_str[MAXLEN];
	while(scanf("%s %s", pre_str, in_str) != EOF)
	{
		int len = strlen(pre_str);
		rebuid_binary_tree(pre_str, in_str, len);
		printf("\n");
	}
	return 0;
} 





// 将字符串分割为三部分
#include<stdio.h>
#include<string.h>

char pre_str[27], in_str[27];						//两个字符串设为全局变量

void rcreat(int p_s, int p_e, int i_s, int i_e);    //重建一棵树

int main()
{
	int len;
	while(scanf("%s%s", pre_str, in_str) != EOF)
	{
		len = strlen(pre_str) - 1;
		rcreat(0, len, 0, len);	
		printf("\n");
	}
	return 0;
}

void rcreat(int p_s, int p_e, int i_s, int i_e)
{
	if(p_e < p_s)                  // 没有一边的子树的时
		return;													//两个if都是递归结束的条件
	if(p_s == p_e)                 //子树只有一个元素时结束
	{
		printf("%c", in_str[i_s]);                   //中序和后序都是左子树开始遍历
		return;
	}
	int i;
	for(i = i_s; ;i++)
	{
		if(pre_str[p_s] == in_str[i])
			break;
	}
	int len = i - i_s;
	rcreat(p_s + 1, p_s +len, i_s, i - 1);         //     把相应的字符串传进来
	rcreat(p_s + len + 1, p_e, i + 1, i_e);
	printf("%c", in_str[i]);
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值