Uva 10305 - Ordering Tasks

Uva 10305 - Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3


给你几个任务,但是有些任务有一定次序,有些任务必须在做完另一个之后才能做。让你输出一种符合条件的顺序(可能有多种,但只需输出一种即可)。

这道题就是一个纯拓扑排序的问题,具体理论和代码可以参考刘汝佳白书P111。明白拓扑排序之后就简单了。

 #include <iostream>
 #include <cstdio>
 #include <string.h>
 #include <queue>
 #define N 102
using namespace std;
int n, m;
int a[N][N], vis[N], in[N];
int main()
{
 #ifndef ONLINE_JUDGE 
    freopen("1.txt", "r", stdin);
 #endif
    int x, y, i, j;
    while (scanf("%d%d", &n, &m), n)
    {
        memset(a, 0, sizeof(a));
        memset(vis, 0, sizeof(vis));
        memset(in, 0, sizeof(in));
        for (i = 0; i < m; i++)
        {
            cin >> x >> y;
            a[x][y] = 1;
            in[y]++;
        }
        x = n;
        while(x--)
        {
            for (i = 1; i <= n; i++)
            {
                if (!in[i] && !vis[i])
                {
                    vis[i] = 1;
                    break;
                }
            }
            cout << i;
            if (x)
            {
                cout << " ";
            }
            else
            {
                cout << endl;
            }
            for (j = 1; j <= n; j++)
            {
                if(a[i][j])
                {
                    in[j]--;
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值