UVa 10397 - Connect the Campus

17 篇文章 0 订阅
16 篇文章 0 订阅

Many new buildings are under construction on the campus of the University of Waterloo. The university has hired bricklayers, electricians, plumbers, and a computer programmer. A computer programmer? Yes, you have been hired to ensure that each building is connected to every other building (directly or indirectly) through the campus network of communication cables.

We will treat each building as a point specified by an x-coordinate and a y-coordinate. Each communication cable connects exactly two buildings, following a straight line between the buildings. Information travels along a cable in both directions. Cables can freely cross each other, but they are only connected together at their endpoints (at buildings).

You have been given a campus map which shows the locations of all buildings and existing communication cables. You must not alter the existing cables. Determine where to install new communication cables so that all buildings are connected. Of course, the university wants you to minimize the amount of new cable that you use.

Fig: University of Waterloo Campus

Input

The input file describes several test case. The description of each test case is given below:

The first line of each test case contains the number of buildings N (1<=N<=750). The buildings are labeled from 1 to N. The next N lines give the x and y coordinates of the buildings. These coordinates are integers with absolute values at most 10000. No two buildings occupy the same point. After that there is a line containing the number of existing cables M (0 <= M <= 1000) followed by M lines describing the existing cables. Each cable is represented by two integers: the building numbers which are directly connected by the cable. There is at most one cable directly connecting each pair of buildings.

Output

For each set of input, output in a single line the total length of the new cables that you plan to use, rounded to two decimal places.

Sample Input

4
103 104
104 100
104 103
100 100
1
4 2

4
103 104

104 100

104 103

100 100

1

4 2

Sample Output

4.41
4.41


最小生成树问题+并查集

kruskai算法

已经连通的点就把他们合并起来

有一点需要注意,楼的编号从1开始


#include<cstdio>
#include <iostream>
#include<algorithm>
#include <math.h>
#include <string.h>
#define N 800
using namespace std;
int coor[N][2], n, m, father[N];
struct Node
{
    int x, y;
    double len;
    friend bool operator < (const Node &a, const Node &b)
    {
        return a.len < b.len;
    }
    void fun()
    {
        int a = coor[x][0] - coor[y][0];
        int b = coor[x][1] - coor[y][1];
        len = sqrt(a*a + b*b + 0.0);
    }
}node[640000];

int find(int x)
{
    if (x != father[x])
    {
        father[x] = find(father[x]);
    }
    return father[x];
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int i, j, k, a, b, t, aa, bb;
    double  ans;
    while(~scanf("%d", &n))
    {
        for (i = 1; i <= n; i++)
        {
            scanf("%d%d", &coor[i][0], &coor[i][1]);
            father[i] = i;
        }
        for (i = 1,k = 0; i <= n; i++)
        {
            for (j = 1;  j < i; j++)
            {
                node[k].x = i;
                node[k].y = j;
                node[k].fun();
                k++;
            }
        }
        scanf("%d", &m);
        for (i = 0; i < m; i++)
        {
            scanf("%d%d", &a, &b);
            aa = find(a);
            bb = find(b);
            if (aa != bb)
            {
                father[aa] = bb;
            }

        }
        sort(node, node + k);
        ans = 0;
        for (i = 0; i < k; i++)
        {
            a = find(node[i].x);
            b = find(node[i].y);
            if (a == b)
            {
                continue;
            }
            ans += node[i].len;
            father[a] = b;
        }
        printf("%.2lf\n", ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值