hdu 1702 ACboy needs your help again!

hdu 1702 ACboy needs your help again!


Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :” I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy.”
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!


Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.


Output

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.


Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT


Sample Output

1
2
2
1
1
2
None
2
3


题意:Acboy 被绑架了,你需要去救他。但是怪兽有一个要求,给你一种数据结构,然后输入一些数据,问你输出时输出的是什么

给数据结构有两种FIFO(队列)和FILO(栈),我们只要按输入,模拟队列或栈就行了,如果是队列(或栈)就申请一个队列(或栈),然后按要求入队(压栈)或出队(出栈),题目并不难,读懂题意是关键。

代码自然少不了~


 #include<iostream>
 #include <cstdio>
 #include <string.h>
 #include <queue>
 #include <stack>
using namespace std;

int main()
{
 #ifndef  ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
 #endif
    int n, m, a;
    char s[5], str[5];
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d%s", &m, str);
        if (!strcmp(str, "FIFO"))
        {
            queue<int> q;
            for (int i = 0; i < m; i++)
            {
                scanf("%s", s);
                if (!strcmp(s, "IN"))
                {
                    cin >> a;
                    q.push(a);
                }
                else
                {
                    if (q.empty())
                    {
                        cout << "None" << endl;
                    }
                    else
                    {
                        cout << q.front() << endl;
                        q.pop();
                    }
                }
            }
        }
        else if (!strcmp(str, "FILO"))
        {
            stack<int> si;
            for (int i = 0; i < m; i++)
            {
                scanf("%s", s);
                if (!strcmp(s, "IN"))
                {
                    cin >> a;
                    si.push(a);
                }
                else
                {
                    if (si.empty())
                    {
                        cout << "None" << endl;
                    }
                    else 
                    {
                            cout << si.top() << endl;
                        si.pop();
                    }
                }
            }
        }
    }
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值