Uva 112 Tree Summing

Uva 112 Tree Summing


Background


LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.

The Problem
Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.

Binary trees are represented in the input file as LISP S-expressions having the following form.

 
empty tree       ::=         ()


tree         ::=         empty tree  tex2html_wrap_inline118  (integer tree tree)


The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

Note that with this formulation all leaves of a tree are of the form (integer () () )

Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.
The Input
The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.
The Output
There should be one line of output for each test case (integer/tree pair) in the input file. For each pair I,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.
Sample Input

22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
10 (3 
     (2 (4 () () )
        (8 () () ) )
     (1 (6 () () )
        (4 () () ) ) )
5 ()

Sample Output
yes
no
yes
no


这道题的难点就是输入数据的处理,以及如何判断是不是到达叶子

一开始使用getchar(),一个个的读取字符,但是一直TLE╥﹏╥..

后来在网上看到某大神的代码,我和我的小伙伴都惊呆了,用cin(cin的详解在这里)输入会自动过滤掉空白字符(如,空格,回车),这样一来输入就简单多了。同时结合cin.good(), cin.clear(), cin.peek(), cin,ignore(), cin,putback()可以很好的解决输入问题

接下来就是判断是不是到达叶子,我们发现当连续读入两对括号时,切括号了没有数字,此时我们就到了叶子。

AC的代码如下(参考网上大神的代码写的,自己写的一直TLE /(ㄒoㄒ)/~~)


#include<iostream>
#include <string.h>
#include <cstdio>
#include <queue>
#include <ctype.h>
using namespace std;
int n, flag;
int fun(int sum)
{
    int values;
    char ch;
    cin >> ch >> values;
    if (cin.good())
    {
        sum += values;
        int a1 = fun(sum);
        int a2 = fun(sum);
        if (!a1 && !a2 && !flag)
        {
            if (n == sum)
                flag = 1;
        }
        cin >> ch;
        return 1;
    }
    else
    {
        cin.clear();
        cin >> ch;
        return 0;
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    while(~scanf("%d", &n))
    {
        flag = 0;
        fun(0);
        if (flag)
        {
            cout << "yes" << endl;
        }
        else
        {
            cout << "no" << endl;
        }
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值