hdu-1495-非常可乐(bfs)

Problem Description

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出”NO”。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以”0 0 0”结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出”NO”。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3


思路:预处理m < n < s,以后处理方便点
初始状态,m,n杯中可乐体积为0,s杯中体积为s;
然后分六种情况:
1, s 倒 m
2, s 倒 n
3, m 倒 n
4, m 倒 s
5, n 倒 m
6, n 倒 s
直到n,s杯中的可乐能等分(此时m杯中体积为0)为止,若不能等分,则输出 NO

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <set>
#include <queue>
#include <algorithm>
#define N 101
#define INF 99999999
#define ll long long
using namespace std;
struct node
{
    int cnt, x, y, z;
};
int s, n, m;
int vis[N][N];
void bfs()
{
    queue<node> q;
    node t1, t2;
    memset(vis, 0, sizeof(vis));
    t1.cnt = 0;
    t1.x = 0;
    t1.y = 0;
    t1.z = s;
    q.push(t1);
    vis[t1.x][t1.y] = 1;
    while(!q.empty())
    {
        t1 = q.front();
        q.pop();
        if (t1.y == t1.z && t1.y == s/2)
        {
            cout << t1.cnt << endl;
            return ;
        }
        t2.cnt = t1.cnt + 1;
        if (t1.x+t1.z > m)      //s->m
        {
            t2.x = m;
            t2.y = t1.y;
            t2.z= t1.x+t1.z-m;
        }
        else
        {
            t2.x = t1.x + t1.z;
            t2.y = t1.y;
            t2.z= 0;
        }
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
        if (t1.y+t1.z > n)  //s->n
        {
            t2.x = t1.x;
            t2.y = n;
            t2.z = t1.y + t1.z - n;
        }
        else
        {
            t2.x = t1.x;
            t2.y = t1.y + t1.z;
            t2.z = 0;
        }
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
        t2.x = t1.x;  //n->s
        t2.y = 0;
        t2.z = t1.y + t1.z;
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
        if(t1.x+t1.y>m)  //n->m
        {
            t2.x = m;
            t2.y = t1.x+t1.y-m;
            t2.z = t1.z;
        }
        else
        {
            t2.x = t1.x + t1.y;
            t2.y = 0;
            t2.z = t1.z;
        }
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
        t2.x = 0;  //m->s
        t2.y = t1.y;
        t2.z = t1.z + t1.x;
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
        if (t1.x+t1.y>n)  //m->n
        {
            t2.x = t1.x+t1.y-n;
            t2.y = n;
            t2.z = t1.z;
        }
        else
        {
            t2.x = 0;
            t2.y = t1.x + t2.y;
            t2.z = t1.z;
        }
        if (!vis[t2.x][t2.y])
        {
            q.push(t2);
            vis[t2.x][t2.y] = 1;
        }
    }
    cout << "NO" << endl;
    return ;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin >> s >> n >> m , s||n||m) 
    {
        if (s&1)
        {
            cout << "NO" << endl;
            continue;
        }
        if (n < m)  swap(n, m);
        bfs();
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值