POJ - 2406——Power Strings (循环节恰好形成字符串的次数)

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:求出循环节恰好形成字符串的循环次数。
思路:len-next[len]是最小形成循环节的长度,len/(len-next[len])就是循环节形成字符串的次数。但是有个坑点(在这个坑点wa了一发)在于len-next[len]是最小的循环长度,在字符串长度取余循环节不等于0的时候,字符串的循环节长度应该是len,答案也就不再是 len/(len-next[len]),而是1。
#include<stdio.h>
#include<algorithm>
#include<string.h>
char a[1000010];
int nextt[1000010],len;
void KMP()
{
    int i=0,j=-1;
    nextt[0]=-1;
    while(i<len)
    {
        if(j==-1||a[i]==a[j])
        {
            nextt[++i]=++j;
        }
        else
            j=nextt[j];
    }

}
int main()
{
    while(~scanf("%s",a),a[0]!='.')
    {

        len=strlen(a);
        KMP();
        int tem=len-nextt[len];
        if(len%tem==0)
        printf("%d\n",len/tem);
        else
            printf("1\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值