15HD_OJ——FatMouse' Trade (贪心算法)

/*
 * Copyright (c) 2014, 烟台大学计算机学院
 * All rights reserved.
 * 文件名称:test.cpp
 * 作    者:李晓凯
 * 完成日期:2015年 5 月 27 日
 * 版 本 号:v1.0
 *
 * 问题描述:
 * 输入描述:
 * 程序输出:

 */

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

 

AC代码:

#include<iostream>
#include <stdio.h>
#include<algorithm>
using namespace std;
struct Food
{
    double x,y;
} food[1005];
int cmp(Food i,Food j)
{
    return i.x*j.y>j.x*i.y;

}
int main()
{
    double s;
    int m,n,i;
    while(scanf("%d%d",&m,&n)!=EOF&&(m>=0&&n>=0))
    {
        for(i=0; i<n; i++)
            scanf("%lf%lf",&food[i].x,&food[i].y);
        sort(food,food+n,cmp);
        s=0;
        for(i=0; i<n; i++)                                 //M可能大于所有food[i].y之和
        {
            if(m>food[i].y)
            {
                s+=food[i].x;
                m-=food[i].y;
            }
            else
            {
                s+=m*food[i].x/food[i].y;
                break;
            }
        }
        printf("%.3lf\n",s);
    }
    return 0;
}


C++错误代码:

#include<iostream>
#include <iostream>
#include <iomanip>
#include<algorithm>
using namespace std;
struct Food
{
    double x,y;
} food[1005];
int cmp(Food i,Food j)
{
    return i.x*j.y>j.x*i.y;

}
int main()
{
    double s;
    int m,n,i;
    while(cin>>m>>n&&(m>=0&&n>=0))
    {
        for(i=0; i<n; i++)
            cin>>food[i].x>>food[i].y;
            sort(food,food+n,cmp);
            s=0;
            for(i=0;i<n;i++)                                   //M可能大于所有food[i].y之和
    {
        if(m>food[i].y)
            {
                s+=food[i].x;
                m=m-food[i].y;
            }
            else
            {
                s+=m*food[i].x/food[i].y;
                break;
            }
        }
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<s<<endl;
    }
    return 0;
}


 不知道为什么用C++编写的就是错的,哎╮(╯▽╰)╭

核心:贪心算法,求最优解,求出Food[i].x/Food[i].y的比值,并按从大到小排序,取出最大的即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值