FatMouse' Trade(贪心)

A - FatMouse’ Trade
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

题意:多组输入,每组数据第一行给出M和N,接着N行,每行两个正整数J[i],F[i]。代表有M磅猫食,N中兑换JavaBeans的汇率,F[i]磅的猫食可以换J[i]的JavaBeans,如果剩下的M不足F[i],则按照比例部分兑换,输出保留三位小数

思路:对J[i]/F[i]的比值进行降序排列,然后逐个取值即可,注意数据类型最好全用double

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
struct node
{
    double J;
    double F;
    double num;//J/F
} num[1000];
bool cmp(node x,node y)
{
    return x.num>y.num;
}
int main()
{
    int M,N;
    while(~scanf("%d%d",&M,&N)&&M!=-1&&N!=-1)
    {
        for(int i=0; i<N; i++)
        {
            scanf("%lf%lf",&num[i].J,&num[i].F);
            num[i].num=num[i].J/num[i].F;
            //printf("%.3lf\n",num[i].num);
        }
        sort(num,num+N,cmp);
        double sum=0.0;
        for(int i=0; i<N; i++)
        {
            if(M>=num[i].F)
            {
                sum+=num[i].J;
                M=M-num[i].F;
            }
            else
            {
                sum=sum+M/num[i].F*num[i].J;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值