PAT甲级2018春季7-4 1147 Heaps (30分)

算法笔记总目录
关键英语单词解释
1147 Heaps (30分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题意:
给出一个完全二叉树,判断是不是堆,是什么堆,输出其后序遍历
思路:
根据完全二叉树的性质 父x 左x2 右x2+1 建树,判断堆,直接利用层序数组里 level[i] 大于还是小于 level[2i] 与 level[2i+1],在后序遍历

相似题及思路可参考A1155

代码一(不建树)

#include<bits/stdc++.h>
using namespace std;
int n,level[1010],x=0;
vector<int> v;
void dfs(int index){
    if (index > n ) return;
    v.push_back(level[index]);
    dfs(index * 2 + 1);
    dfs(index * 2);
}
int main(){
	scanf("%d %d",&x,&n);
	for(int j=0;j<x;j++){
		int isMin = 1, isMax = 1;
		v.clear();
	    for (int i = 1; i <= n; i++) scanf("%d", &level[i]);
	    dfs(1);
        for (int i = 2; i <= n; i++) {
           if (level[i/2] > level[i]) isMin = 0;
           if (level[i/2] < level[i]) isMax = 0;
        }
        if (isMin == 1)  printf("Min Heap");
        else  printf("%s", isMax == 1 ? "Max Heap" : "Not Heap");
        printf("\n");
        printf("%d",v[v.size()-1]);
        for(int i=v.size()-2;i>=0;i--)printf(" %d",v[i]);
        if(j<x-1)printf("\n");
	}
    return 0;
} 

在这里插入图片描述

代码二(建树)

#include<bits/stdc++.h>
using namespace std;
struct node{
	int val;
	node *lchild,*rchild;
};
int n,level[1010],x=0,flag=0;
node *create(int x,node *root)//1号位开始 
{
	if(x>n) return NULL;
	root->val=level[x];
    root->lchild=create(x*2,new node);
    root->rchild=create(x*2+1,new node);
	return root;
}

void printTree(node *root){
	if(root == NULL) return;
	printTree(root->lchild);
    printTree(root->rchild);
	if(flag==1)printf(" %d",root->val);
	else printf("%d",root->val);
	flag=1;
}
int main(){
	scanf("%d %d",&x,&n);
	for(int j=0;j<x;j++){
		int isMin = 1, isMax = 1;
		flag=0;
		node *root = new node;
	    for (int i = 1; i <= n; i++) scanf("%d", &level[i]);
        for (int i = 2; i <= n; i++) {
           if (level[i/2] > level[i]) isMin = 0;
           if (level[i/2] < level[i]) isMax = 0;
        }
        if (isMin == 1)  printf("Min Heap");
        else  printf("%s", isMax == 1 ? "Max Heap" : "Not Heap");
        printf("\n");
        printTree(create(1,root));	
        if(j<x-1)printf("\n");
	}
    return 0;
} 

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值