PAT甲级2017冬7-3 1142 Maximal Clique (25分)

算法笔记总目录
关键英语单词解释
本题代码与PAT甲级2019冬7-3 Summit(1166)除输出不一样外,其他不变。
1142 Maximal Clique (25分)
A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.
Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
#include<bits/stdc++.h>
using namespace std;
int e[205][205];
int a[205];
int v[205];
int n,m;
int main(){
    cin>>n>>m;
    memset(e,0,sizeof(e));
    for(int i=1;i<=m;i++){
        int u,v;
        cin>>u>>v;
        e[u][v]=e[v][u]=1;//邻接矩阵存储 
    }
    int k;
    cin>>k;
    int num;
    for(int i=1;i<=k;i++){//k个询问 
        cin>>num;
        memset(v,0,sizeof(v));//v来标记所询问的num个点 
        for(int j=1;j<=num;j++) {
            cin>>a[j];
            v[a[j]]=1;//做上标记 
        }
        int f=1;//是不是两两相连 
        for(int j=1;j<=num;j++){
            for(int p=j+1;p<=num;p++){
                if(e[a[j]][a[p]]!=1) f=0;
                break;
            }
        }
        if(!f) cout<<"Not a Clique";
        else{//如果是两两相连 
            int ans=-1;//是否存在 
            for(int j=1;j<=n;j++){//查询存不存在一个点与这num个点都相连 
                if(v[j]) continue;//本身是num个点里的不算 
                int ff=1; 
                for(int p=1;p<=num;p++){
                    if(e[a[p]][j]!=1){
                        ff=0;
                        break;    
                    }
                }
                if(ff) {//满足与num中的每个点都相连 
                    ans=j;//存在 
                    break;
                }
            }
            if(ans!=-1){//存在 
                cout<<"Not Maximal";
            }else{//不存在 
                cout<<"Yes"; 
            }
        }
        if(i!=k) cout<<endl;//行末无空行 
    }
    return 0; 
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值